Third party providers service degradation

Incident Report for Obligo

Resolved

Third party service provider issue was fully resolved, and all services are fully operational.
Posted Nov 18, 2025 - 18:10 UTC

Monitoring

Third party service provider issue was resolved, and all systems should now be fully operational. We are continuing to monitor and make sure everything is working properly.
Posted Nov 18, 2025 - 16:35 UTC

Identified

Heads up! Some Obligo services are temporarily degraded due to a third party provider outage. Renters may experience issues with payments and qualification — we’re working to restore full functionality as soon as possible.
Posted Nov 18, 2025 - 13:46 UTC
This incident affected: Renter Console (tenant.myobligo.com).